Главная страница
Подробнее на сайте: http://leadnews.ru http://dohodok.ruhttp://grand-finance.ruhttp://tryjoomla.nethttp://my-houseroom.ruhttp://buy-immobility.ru
http://kupil-jilie.ru http://health-treatment.ruhttp://choose-house.ruhttp://joomspider.com
http://my-immobility.ruhttp://repair-dwelling.ru http://java-code.ruhttp://body-treatment.ruhttp://maintain-health.ru

Миграция с Joomla 2.5 на Joomla 3.x

Приветствую вас уважаемый посетитель сайта Joomla-Shablons.com! Сегодня мы с вами поговорим о процесс миграции Joomla 2.5.28 на Joomla 3.4.x. С первого января 2015 года после обновления до версии джумла движка до версии 2.5.28, в админке сайта стало выводиться сообщение о том, что официально прекращается поддержка линейки версии php-скрипта Joomla 2.5. Соответственно версия Joomla 2.5.28 является последней версией в данной линейки 2.5.x джумла скрипта, и обновлений больше не будет. Данная ситуация сайтам особо ничем не грозит кроме того, что не будет больше обновлений касаемых устранения уязвимостей движка. Именно поэтому на официальном интернет проекте http://joomla.org появилась информация о том, как пройти процесс (обновления) миграции с версии Joomla 2.5.28 на Joomla 3.4.x.

Миграция с Joomla 2.5.28 на Joomla 3.4.8 (данная версия является на данном этапе самой последней в линейке 3.x) не так-то и просто, особенно если у вас сайт больших размеров и имеет большое количество страниц с контентом. Также осложняет процесс миграции с Joomla 2.5.28 на Joomla 3.4.8 тот факт, если у вас на сайте установлено большое количество сторонних расширений. 

Если у вас сайт не больших размеров, который использует минимальное количество расширений (это могут быть компоненты, модули и плагины), то тогда весь процесс миграции сайта с версии Joomla 2.5.28 на Joomla 3.4.8 будет проходить значительно легче. Более сложным и трудоёмким процессом будет миграция на актуальную версию движка Joomla 3.4.9 c версии Joomla 1.5 (схема обновления имеется и для такой древней версии джумла движка версии 1.5).

Как реализовать миграцию с Joomla 2.5.28 на Joomla 3.4.8 вы сможете узнать ниже по тексту. И так, начнём!

Процесс миграции с Joomla 2.5 на Joomla 3.4.8

Если вы решили сделать апгрейд вашего сайта на актуальную версию СMS Joomla 3.x, вам нужно будет сдлать следующие пункты:

    1. Обновить свой сайта работающий на движке джумлы 2.5.x до последней версии 2.5 линейки, а это версия 2.5.28;
    2. Убедиться в том, что ваш хостинг поддерживает все минимальные требования для Joomla 3.x версии. Версия интерпритатора php должен быть не ниже версии 5.3 (рекомендуется 5.4+), и база данных MySQL 5.1+;
    3. Создайте резервную опию вашего рабочего проекта (сделайте бэкап файлов сайта и MySQL базы), чтобы если что, вы смогли откатиться обратно, если что-то при процессе миграции пойдёт не так;
    4. Создайте список всех установленных расширения для вашего сайта, которые вам необходимы будут после обновления движка на актуальную версию php-скрипта. Сторонними расширениями можно назвать все те расширения, в которых в столбце под названием "автор" написан авто отличительны от "Joomla Project". Есть расширения которые где указаны в расширения другие авторы, и такие расширения вы не можете удалить, поскольку они по сути являются системными расширениями движка и имеют некую защиту от удаления. Вам необходимо будет зайти в административной панели вашего джумла сайта в раздел "Менеджер расширений" > "Обновление" и проверить, есть ли обновление для ваших уже установленных расширений, нажав на соответственную кнопку "найти обновление". Если обновления для ваших расширений имеются, то вам стоит их все обновить.
    5. Дальше вам необходимо будет перейти во вкладку под названием "Управление" и выбрать там "Пакет", поскольку при удаления какого либо расширения, связанные с ним все дополнения  (компоненты, модули, плагины) будут деинсталированы. Дальше вы просто по очереди удаляете все ненужные вам установленные расширения в движке выбирая другой "тип". Все расширения которые нужны, вам надо будет определиться, есть ли они под актуальную версию Joomla 3.x. У некоторых расширений вы увидите напротив значок рядом с их версией, который вам даст информацию о доступности новой версии. Если какие либо установленные расширения не имеет информационного значка, то вам придётся в ручную разбираться с подобными расширениями, переходя на сайты разработчиков, и выискивая там информацию о поддерживаемых версиях движка Joomla.

Далее мы имеем два варианта развития событий по миграции с Joomla 2.5.28 на Joomla 3.4.x

Все ваши установленные в движок расширения имеют пакет совместимости как с Joomla 2.5, так и с Joomla 3.x. Если это так, то вы сможете его смело обновлять у себя на сайте;

Ваши установленные расширения имеют как версии для Joomla 2.5.x, так и для версии движка 3.x. В таком случае вам необходимо будет деинсталировать все расширения версии 2.5, и после обновления движка до версии дужмла 3.x, возможно будет прямо из админки сайта поставить все нужные вам расширения, за счёт новой возможности установки компонентом, модулей и плагинов прямо из административной части с официального сайта http://extentions.joomla.org. Заметим, что после переустановки расширений, вы можете потерять все настройки в них и какие либо  имеющиеся там данные).

Также стоит уделить внимание вашему шаблону. Если шаблон также имеет разные пакеты, то есть установочный пакет для Joomla 2.5, и отдельный пакет для Joomla 3.x, то вам нежно будет удалить старый шаблон, и на актуальную версию поставить пакет под актуальную версию php-скрипта джумла 3.x. Как только вы удалите старый свой шаблон, что стоял у вас на версии 2.5, переключитесь временно на шаблон, который поставляется с движком по умолчанию.

Как только вы удалите все расширения, которые не совместимы с Joomla 3.x, необходимо будет в админ панели сайта зайти в "Общие настройки", и там во вкладку "Сервер". Там следует выставить максимальное значение параметру "Максимум".

  1. В админ панели зайдите в раздел "Менеджер плагинов" и отключите плагин под названием "Система -запомнить меня".
  2. Перейдите в пункт меню под названием "Компоненты" > "Обновление Joomla" и нажмите там "Настройки" и там вам нужно будет изменить сервер обновлений на "Дистрибутивы Joomla с краткосрочной поддержкой". Как только вы сохраните настройки у вас должно в админке вывестись сообщение о доступной версии обновлении Joomla до версии 3.4.8. Установите данную версию php-скрипта Joomla. Как только обновите движок до актуальной версии джумлу, далее очистите кэш.
  3. Дальше вам необходимо будет перейти в "Менеджер расширений" и выбрать слева подменю "База данных". После выбора данного пункта, нажмите на кнопку "исправить".
  4. Следующим шагом вам надо будет перейти в подменю "Поиск". Нажмите на "найти" кнопку и обновите доступные для обновления новые версии всех ваших установленных в движок расширений.
  5. После всех проделанных выше манипуляций, включите плагин "Система - Запомнить меня".
  6. Перейдите в админке в раздел "Менеджер материалов" и там нажмите на кнопку "Настройки" и выберите пункт "Форма редактирования", где вам нужно будет включить параметр "Save History".
  7. Теперь вы можете устанавливать новые вывести расширений, которые поддерживает Joomla 3.4.x, включая новый шаблон адаптированный под 3.4.x версию php-скрипта Joomla.
  8. Чтобы завершить процесс миграции с Joomla 2.5.28 на Joomla 3.4.x, вам необходимо будет удалить языковый пакет и поставить актуальный языковый пакет для 3.4.x версии джумлы.

Это все пункты, которые вам нужно будет сделать для миграции вашего сайта на актуальную версию php-скрипта Joomla 3.4.8. Желаем вам чтобы процесс миграции на актуальную версию скрипта у вас прошёл как по маслу!

Джумла веб студии

Счётчик

О интернет сервисе

На данном сайте вы сможете скачать шаблоны для Joomla движка разных версий от известных зарубежных веб-студий. Если вы хотите создать современный коммерческий сайт, то система управления джумла в тандеме с одним из представленных на данном сайте шаблоном, будет отличным вариантом для создания качественного сайта, с гибким функционалом.